**> So my first two questions are:
> 
> 1. How to do a simple test that confirms whether or not
> Oniguruma is there?

Currently not supported.
I will add a constant Regexp::ENGINE = "Oniguruma 2.5.2" for Ruby 1.8.X.
Then, oniguruma check will be
(RUBY_VERSION >= "1.9.0" || (defined?(Regexp::ENGINE) && Regexp::ENGINE.include?('Oniguruma')))

> 2. How to build the stable snapshot with Oniguruma?

Same as release version of Ruby 1.8.4.
(INSTALL-RUBY file in onigd2_5_1.tar.gz)
--
K.Kosako