------_extPart_001_01C60B7A.AB4F1CEC
Content-Type: text/plain;
	charsetso-8859-1"
Content-Transfer-Encoding: quoted-printable

Hi,

Do you really have anything that relies on Ruby or its libraries, besides Ruby?
I'm running Mandrake (Mandriva...) 10.2, and it came with 1.8.2. I just uninstalled the RPMs for 1.8.2, then compiled and installed 1.8.4 from source - no problems.

HTH

-Justin


-----Original Message-----
From: Steve Litt [mailto:slitt / earthlink.net]
Sent: Tue 12/27/2005 9:54 PM
To: ruby-talk ML
Subject: How to upgrade Ruby
 
Hi all,

My Mandrake 10.0 (don't laugh, I've been slow to upgrade) has Ruby 1.8.1. I 
need at least 1.8.2 in order to use Rails, according to the book I dissed and 
now am fervently reading.

Is there a simple way of upgrading my Ruby without going through dependency 
hell and maybe busting half my other stuff?

SteveT

Steve Litt
http://www.troubleshooters.com
slitt / troubleshooters.com



------_extPart_001_01C60B7A.AB4F1CEC--