Hi Jim,

Thanks a lot for your reply.
Yes, ruby version is the issue at my end.

I am going to add the following line in my spec file
spec.required_ruby_version = '>= 1.8.3'


Thanks again,
Mohammad Khan



On 12/21/05, Jim Weirich <jim / weirichhouse.org> wrote:
> Mohammad Khan wrote:
> > Hello,
> >
> > I am trying to make a gem package for one of my library that I am
> > going to make avaiable soon. Problem is, I can successfully install my
> > gem on the machine where I build the gem. But if I copy that gem to
> > another machine and try to install it I get
> >
> > [root@ruby-agi download]# gem install ruby-agi-0.0.3.gem
> > Attempting local installation of 'ruby-agi-0.0.3.gem'
> > ERROR:  Error installing gem ruby-agi-0.0.3.gem[.gem]: parse error on
> > line 0, col 31: `!ruby/object:Gem::Specification '
>
> Sounds like you built the gem on a Ruby 1.8.3 system and are trying to
> install it on a Ruby 1.8.2 system.  Version 1.8.3 has a backwards
> compatibility bug in the Yaml code such that the yaml produced on 1.8.3
> cannot be read on earlier systems.
>
> Fortunately, I've heard rumours that 1.8.4 (out real soon now) will
> correct that bug.
>
> --
> -- Jim Weirich
>
> --
> Posted via http://www.ruby-forum.com/.
>
>