On Thu, 15 Dec 2005, Eero Saynatkari wrote:

> unknown wrote:
>> On Thu, 15 Dec 2005 dblack / wobblini.net wrote:
>>
>>>>    class Module
>>>>      def inherit other
>>>
>>> My main suggestion would be to rename this method.  I don't think this
>>> is an inheritance operation.  At least, it seems potentially confusing
>>> to "inherit" a module, since inheritance already means something else
>>> and modules already do other things.
>>
>> true true.  hmmm... how is it different here?  you'll have all the
>> class_methods and all the instance_methods....  and Superclass === self
>> with
>> be true...
>>
>> i'm sure there must be a catch though...
>>
>> can you think of a better name?
>
> Well.. #include :)
> Also, of course, #import, #mix, #combine and #greyskull.

i like mix!

maybe #mixin.  anyone know if there are plans for that?

-a
-- 
===============================================================================
| ara [dot] t [dot] howard [at] noaa [dot] gov
| all happiness comes from the desire for others to be happy.  all misery
| comes from the desire for oneself to be happy.
| -- bodhicaryavatara
===============================================================================