unknown wrote:
> On Thu, 15 Dec 2005 dblack / wobblini.net wrote:
> 
>>>    class Module
>>>      def inherit other
>>
>> My main suggestion would be to rename this method.  I don't think this
>> is an inheritance operation.  At least, it seems potentially confusing
>> to "inherit" a module, since inheritance already means something else
>> and modules already do other things.
> 
> true true.  hmmm... how is it different here?  you'll have all the
> class_methods and all the instance_methods....  and Superclass === self 
> with
> be true...
> 
> i'm sure there must be a catch though...
> 
> can you think of a better name?

Well.. #include :)
Also, of course, #import, #mix, #combine and #greyskull.

The design itself seems to be fine. An alternative would
be to create an enhanced #include which would take over
if require 'better-include' is encountered (until such
time that this makes it to the stdlib).

> cheers.
> 
> -a


E

-- 
Posted via http://www.ruby-forum.com/.