Hmmm... my guess is the RUBYOPT setting. Make sure you have this
environment variable set. If using Linux

  > export RUBYOPT="-rubygems"

You'll probably want that in your default shell setup. Give that a go
and let me know if that doesn't fix the problem. (Oh, you'll have to
uninstall the manual installation too for the gem to work. Go to your
ruby site dir, on Linux something like /usr/local/lib/site_ruby/1.8 and
delete the facet dir and facets.rb file.)

Also a little bonus for you. Uninstall the facets gem

  gem uninstall facets

And reinstall with:

  gem install --version "=1.0.0"  facets

Not offically released yet, but it will be "real soon now".

HTH,
T.