Hi,

In message "Re: [BUG] string range membership"
    on Tue, 29 Nov 2005 00:16:49 +0900, "Warren Brown" <warrenbrown / aquire.com> writes:

|    OK, I think I see why they were changed to be the same, but I really
|don't understand the choice of functionality that was kept.  For
|everything except Ranges, #include? and #member? checks for set
|membership.  In Ranges, #include? and #member? don't check for set
|membership, they check for interval coverage instead.  This seems worse
|than the original situation where at least #member? meant the same thing
|everywhere.

I don't remember exactly but it's for the sake of performance.  I've
thinking about this issue for last few days, and it could be made
better by treating numbers specially, just like we did for min and max
in Range.

|    Anyway, could Range#include? and Range#member? be changed back to a
|membership check and a new method be added to Range for interval
|coverage, or would that break too much backwards compatibility?  Several
|names come to mind for the new method: #between? (my personal favorite),
|#betwixt? (kind of silly, but could be fun), #cover?, #surround?,
|#bound?, #inside?, #within?, #in_range?, #in_interval?, #in?
|
|    If the current behavior of the Range methods can't be changed, names
|for membership checks (not including #member? - yuck!) could be:
|#among?, #amid?, #amidst?, #component?, #constituent?, #part?, #has?,
|#in?
|
|    What do you think?

Thank you for the candidates.  I'd like to hear opinion from others
(especially from English speakers).

							matz.