On 11/26/05, David A. Black <dblack / wobblini.net> wrote:
> What version of Ruby are you using?
>
> $ ruby -ve '"a"..3'
> ruby 1.8.3 (2005-09-21) [powerpc-darwin8.3.0]
> -e:1: warning: useless use of .. in void context
> -e:1: bad value for range (ArgumentError)

C:\>ruby -ve '"a"..3'
ruby 1.8.2 (2005-02-01) [i386-mswin32]
-e:1: warning: useless use of .. in void context

Strange...

weill samg$ ruby -ve '"a"..3'
ruby 1.8.0 (2003-08-04) [i686-linux]
-e:1: warning: useless use of .. in void context
-e:1: bad value for range (ArgumentError)

Double-strange... I wonder if it's a windows thing or a version thing
(and if so why it only pops up somewhere between 1.8.0 and 1.8.3).

Sam