On Tuesday 22 November 2005 18:12, Robert Klemme wrote:
> 8:05:35 [~]: ruby -e 'p PLATFORM, RUBY_VERSION'
> "i386-cygwin"
> "1.8.3"
>
> Now, how do you classify that? ormally I'd say unix but there
> might be application cases where it's more on the Windows side...

Perhaps:

  Platform.unix?    # => true
  Platform.windows? # => false
  Platform.cygwin?  # => true

Kind regards,
  Stefan