The 1.0.1 release of ruby-growl allows ruby-growl to work on Tiger's  
Ruby 1.8.2.

Special thanks to Aslak Hellesoy for pointing out the problem and  
Daniel Berger for informing me that Array#pack is broken on Tiger.

ruby-growl is a UDP notification tool for Growl.

What is Growl?

Growl is a global notification system for Mac OS X. Applications can  
register messages which Growl displays on the screen in a variety of  
ways depending upon your preferences.

Why ruby-growl?

Growl's existing Ruby bindings only work on Macs, and I wanted my non- 
Mac machines to be able to send Growl notifications. I peeked inside  
Growl's remote-notification capabilities and wrote up some code that  
uses UDP to send Growl notifications across the network.

For more information, see:

http://segment7.net/projects/ruby/growl/

To install:

gem install ruby-growl

Or you can fetch the gem (or source .tgz) from RubyForge:

http://rubyforge.org/frs/?group_id=1100

--
Eric Hodel - drbrain / segment7.net - http://segment7.net
FEC2 57F1 D465 EB15 5D6E  7C11 332A 551C 796C 9F04