mathew wrote:
>
> [...] you just need to either use a more recent Ruby, or [...]
>


I'd be tempted to just scoop  http.rb, https.rb  &  protocol.rb  out of:
http://www.ruby-lang.org/cgi-bin/cvsweb.cgi/ruby/lib/net/?only_with_tag=v1_8_3
into a new directory and prepend to $:


daz