On Fri, Nov 11, 2005 at 04:27:13AM +0900, cles2 / comcast.net wrote:
> Converting from Windows XP to Linux, I have formatted one of my
> computers with Ubuntu 5,10 which has Ruby 1.8.3 installed. I can create
> and execute ruby files (.rb) with no problems. However, when i try irb
> bash reports that the file cannot be found. Same with ri.

sudo apt-get install irb ri
 
> I'm an experienced programmer but getting set up is driving me nuts.
> I'm also having problems trying to download RubyGems and Rails, but I
> have not really progressed far enough to worry about that yet. Help?

When it comes time to get RubyGems and Rails you'll need zlib and yaml.

sudo apt-get install libyaml-ruby1.8 libzlib-ruby1.8

marcel
--
Marcel Molina Jr. <marcel / vernix.org>