In version  182-15 of the One-Click Installer there is a problem
running FXRuby programs using rubyw.exe, but they run correctly with
ruby.exe.

I believe this problem does not exist in 182-14, which has the same
version of, just different versions of the pre-installed extensions.

I will make sure that this is resolved by the time we release the
installer for 1.8.4 (hopefully around the end of this year).

Curt

On 10/31/05, Dirk Meijer <hawkman.gelooft / gmail.com> wrote:
> hi everyone,
> just a few months ago, i was able to run programs that use fxruby, since
> recently, it has not been working, but i'm not as much into ruby that i'd
> write a fxruby program.. however, i would like to get it back to work.
> i use windows xp, sp2, on-click installer 1.8.2-15
> and i get the following error:
>  d:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:144:in `activate': can't
> activate fxruby (= 1.2.6), already activated fxruby-1.4.2-mswin32]
> (Gem::Exception)
> from d:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:23:in
> `require'
> from d:/ruby/lib/ruby/gems/1.8/gems/fxri-0.3.2/./fxri:10
> from D:/ruby/bin/fxri:18:in `load'
> from D:/ruby/bin/fxri:18
>  does anyone know how to fix this problem?
> greetings, Dirk.
>
>