On 10/31/05, Dirk Meijer <hawkman.gelooft / gmail.com> wrote:

> just a few months ago, i was able to run programs that use fxruby, since
> recently, it has not been working, but i'm not as much into ruby that i'd
> write a fxruby program.. however, i would like to get it back to work.
> i use windows xp, sp2, on-click installer 1.8.2-15
> and i get the following error:
>  d:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:144:in `activate': can't
> activate fxruby (= 1.2.6), already activated fxruby-1.4.2-mswin32]
> (Gem::Exception)
> from d:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:23:in
> `require'
> from d:/ruby/lib/ruby/gems/1.8/gems/fxri-0.3.2/./fxri:10
> from D:/ruby/bin/fxri:18:in `load'
> from D:/ruby/bin/fxri:18
>  does anyone know how to fix this problem?

Just a note to try to pin down the source of the problem: It's not a
problem with FXRuby. It *appears* to be a problem with what "fxri" (an
application that happens to use FXRuby) is trying to do to when it
tries to "require" the FXRuby gem.