Wai-Sun Chia <waisun.chia / msa.dec.com> writes:

> * Ruby (this is a hacked version from Mandrake, RH's version sucked)

if you use enable-shared, you'd better use:

--- ruby.spec.old	Fri Jun  8 14:16:08 2001
+++ ruby.spec	Fri Jun  8 14:16:19 2001
@@ -129,6 +129,7 @@
 %{_mandir}/*/*
 %{_datadir}/emacs/site-lisp/*
 %config(noreplace) %{_sysconfdir}/emacs/site-start.d/*
+%{_libdir}/libruby.so.*
 
 %files doc
 %defattr(-, root, root)
@@ -143,7 +144,7 @@
 %files devel
 %defattr(-, root, root)
 %{_libdir}/%{name}/%{subver}/%{my_target_cpu}-%{_host_os}/*.[ah]
-%{_libdir}/libruby.so*
+%{_libdir}/libruby.so
 
 %files tk
 %defattr(-, root, root)


otherwise your ruby package depends on ruby-devel ;p