Hi,

>From: Zach Dennis <zdennis / mktec.com>
>Reply-To: ruby-talk / ruby-lang.org
>To: ruby-talk / ruby-lang.org (ruby-talk ML)
>Subject: Re: MySQL Ruby On Windows , Why?
>Date: Thu, 27 Oct 2005 22:56:36 +0900
>
>zdennis wrote:
>>Park Heesob wrote:
>>
>>>Hi,
>>>
>>>>From: Zach Dennis <zdennis / mktec.com>
>>>>Reply-To: ruby-talk / ruby-lang.org
>>>>To: ruby-talk / ruby-lang.org (ruby-talk ML)
>>>>Subject: MySQL Ruby On Windows , Why?
>>>>Date: Thu, 27 Oct 2005 02:44:51 +0900
>>>>
>>>>Why does making the mysql-ruby .so suck so bad on windows? And for 
>>>>anyone who has made it can they maybe post why they had to do to get it 
>>>>to actually compile?
>>>>
>>>
>>>Do you mean my posting
>>>http://groups.google.co.kr/group/comp.lang.ruby/msg/6b3a305604ee2299
>>>It should be 
>>>http://www.ruby-talk.org/cgi-bin/scat.rb/ruby/ruby-talk/161578
>>>But why not archived?
>>>
>>>I belive the mysql-ruby-win package was compiled with fastcall option.
>>>Therefore the find_library checking for 'mysql_query' function is failed 
>>>with argument error.
>>>The same to 'mysql_ssl_set' function.
>>>So I change 'mysql_query' to 'mysql_reconnect' and remove 'mysql_ssl_set' 
>>>checking.
>>>
>>
>>Thank you Park for responding. Tomorrow when I get to the office I am 
>>going to try to recompile following your previous post, and this last 
>>post. With any luck I am going to throw it up on a few different spots on 
>>the web so perhaps it will get out there a bit more.
>
>I am running Windows 2k. I tried the solution that worked for you on 
>Windows XP but I still get...
>
>ruby extconf.rb --with-mysql-include="C:\Program Files\MySQL\MySQL Server 
>4.1\include" --with-mysql-lib="C:\Program Files\MySQL\MySQL Server  
>4.1\lib\opt"
>
>checking for mysql_reconnect() in mysqlclient.lib... no
>checking for main() in m.lib... yes
>checking for mysql_reconnect() in mysqlclient.lib... no
>checking for main() in z.lib... no
>checking for mysql_reconnect() in mysqlclient.lib... no
>checking for main() in socket.lib... no
>checking for mysql_reconnect() in mysqlclient.lib... no
>checking for main() in nsl.lib... no
>checking for mysql_reconnect() in mysqlclient.lib... no
>
>I have verified the location of my lib files and my include files, but no 
>go. Perhaps I will just download your binary =)
>
Didn't you remove the line
libs = ['m', 'z', 'socket', 'nsl']
from extconf.rb ?
Please try with the same patched extconf.rb as in my previous post.

Regards,

Park Heesob