--kVXhAStRUZ/+rrGn
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Wed, Oct 26, 2005 at 04:17:46AM +0900, Dominik Bathon wrote:
> I would like to propose a shortcut for block arguments (the magic block  
> argument ;-)

<snip>

> I am not sure about the @ sign, other possibilities might be $ or $ plus  
> something or something completely different, it should just be short.

Since the function of such a variable is to act as a pronoun, it makes
more readable code if you name it "it":

my_array.each { print it }

I first saw this idea in the proposal for Arc.

> And nobody would be forced to use it, it would be completely optional,  
> just an alternative.

This is not a good argument, because reading is as important (or more
important!) than writing.  If someone chooses to write it, everyone
needs to be able to read it, whether they like it or not.

regards,
Ed

--kVXhAStRUZ/+rrGn
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFDXojgnhUz11p9MSARApmYAJ9GYTp6lawXzd09nNQpIheEF6hW/ACfWJZX
bc+bhvTpUuc1nrYPMx3R+UAOV
-----END PGP SIGNATURE-----

--kVXhAStRUZ/+rrGn--