One more thing.  This RCR introduces a new reserved word to the
language: "cut".  This will break any code already using "cut"
as a variable or method name (and calling it with no receiver).
 An additional reserved word should not be introduced to the
language unless you really need it.  So far, you haven't
demonstrated that a "cut" really provides anything else useful
over what you could do with the #preclude part of your RCR. 
#preclude would just be another method so it shouldn't cause
compatibility issues like "cut".



	
		
__________________________________ 
Yahoo! Mail - PC Magazine Editors' Choice 2005 
http://mail.yahoo.com