So I had ok luck compiling on an AIX 5.3 box, but unfortunately I have
no ability to upgrade the machine I need ruby on to 5.3, at least not
in the short-term.  Is there really nobody else who's run into the
problem?

Thanks,
Will