Hello list,

here a really simple Haskell function, which sums all elements of a list
(from the book "The Haskell School of Expression"):
--------------------------------
listSum [] = 0
listSum (x : xs) = x + listSum xs
--------------------------------

Which is the best way to say it in Ruby (functional style)? Don't use
'enum.inject', please!


Thanks for your thoughts.
Greetings, 
Andreas Semt