I am installing Ruby 1.8.3 on fresh install of Red Hat Fedora Core 4.
Ultimately I would like to install Gem then Rails on the server... Gem
installs but produces an error :
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require__': no such file to load -- stringio (LoadError)

I was told to re-make Ruby and see if any errors are produced. 

The "make install" command installs Ruby but produces this error:

./miniruby ./ext/extmk.rb --dest-dir="" --make="make" --mflags=""
--make-flags="" --extout=".ext" --extension  --extstatic  -- install
cp -r ./.ext/. /usr/local/lib/ruby/1.8
/root/Desktop/ruby-1.8.3/lib/fileutils.rb:1237:in `copy': unknown file
type: ./.ex t/. (RuntimeError)
        from /root/Desktop/ruby-1.8.3/lib/fileutils.rb:447:in
`copy_entry'
        from /root/Desktop/ruby-1.8.3/lib/fileutils.rb:1306:in
`traverse'
        from /root/Desktop/ruby-1.8.3/lib/fileutils.rb:445:in
`copy_entry'
        from /root/Desktop/ruby-1.8.3/lib/fileutils.rb:423:in `cp_r'
        from /root/Desktop/ruby-1.8.3/lib/fileutils.rb:1377:in
`fu_each_src_dest'
        from /root/Desktop/ruby-1.8.3/lib/fileutils.rb:1391:in
`fu_each_src_dest0'
        from /root/Desktop/ruby-1.8.3/lib/fileutils.rb:1375:in
`fu_each_src_dest'
        from /root/Desktop/ruby-1.8.3/lib/fileutils.rb:422:in `cp_r'
        from ./ext/extmk.rb:364
make: *** [do-install-ext] Error 1


Any help would be greatly appreciated.
Thanks!
Michael