> a reasonable solution.  i guess i'm wondering if any rubyists out there
> are a
> point of contact for them or what - i don't understand how they interface
> to
> an open-source project like ruby.

This link (https://rhn.redhat.com/errata/RHSA-2005-543.html) shows a
security advisory for Ruby 1.8 via Redhat Enterprise.  I gave up Redhat
long ago, but it looks to me like you can upgrade your Ruby version to
1.8.x.

Caleb