Hi --

On Sun, 9 Oct 2005, Devin Mullins wrote:

> 3. Indeed, you're right. It's more important to have a small set of cohesive 
> and perfect doohickeys than a large set of jumbled and POS ones. So, fine, 
> let us continue the select! discussion....

What's POS?

> I say we name it select! and alias as keep! -- that way, somebody ri'ing it 
> will be able to infer its meaning the English way, and somebody not ri'ing 
> will be able to infer its meaning from the parallels already drawn in 90+% of 
> the core bang methods (where x.foo! _=_ x = x.foo... sort of).

(But how many times is foo! not, on its own, a good method name for
what it does?  I still prefer that there not be a method called
select!, but I dare say that's pretty evident by now :-)

keep! implies keep.  I think keep (without the !) would be an inplace
operation already.  Or maybe keep_all { <test> }.


David

-- 
David A. Black
dblack / wobblini.net