Bret Pettichord wrote:

> I checked the load path in my testsuite, after executing "require 
> 'watir'". And i saw that the gem path to watir was on the load path 
> before the directory that had the development version. I don't use 
> require_gem. But you are telling me that that wasn't supposed to happen.

Hmmm... I don't know a lot about gems, but it's certainly counter to my 
setup:

C:\prog\rubycode>notepad binding_of_caller.rb

C:\prog\rubycode>type binding_of_caller.rb
puts <<'YAY!!!'
I'm a little teapot
Short and stout.
This is my handle.
This is my spout.

When I get all steamed up,
Hear me shout:
"Tip me over and
Pour me out!"
YAY!!!

C:\prog\rubycode>notepad test.rb

C:\prog\rubycode>type test.rb
require 'pp'
require 'binding_of_caller'
puts
pp $:

C:\prog\rubycode>ruby test.rb
I'm a little teapot
Short and stout.
This is my handle.
This is my spout.

When I get all steamed up,
Hear me shout:
"Tip me over and
Pour me out!"

["c:/prog/ruby/lib/ruby/site_ruby/1.8",
 "c:/prog/ruby/lib/ruby/site_ruby/1.8/i386-msvcrt",
 "c:/prog/ruby/lib/ruby/site_ruby",
 "c:/prog/ruby/lib/ruby/1.8",
 "c:/prog/ruby/lib/ruby/1.8/i386-mswin32",
 "."]

C:\prog\rubycode>del binding_of_caller.rb

C:\prog\rubycode>ruby test.rb

["c:/prog/ruby/lib/ruby/gems/1.8/gems/rails-0.13.1/bin",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/rails-0.13.1/lib",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/actionwebservice-0.8.1/lib/action_web_service/vendor/",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/actionwebservice-0.8.1/bin",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/actionwebservice-0.8.1/lib",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/actionmailer-1.0.1/lib/action_mailer/vendor/",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/actionmailer-1.0.1/bin",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/actionmailer-1.0.1/lib",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_view/helpers/../../action_controller/vendor/html-scanner",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_view/vendor",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/../../activesupport/lib",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/actionpack-1.9.1/bin",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/activesupport-1.1.1/lib",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/activerecord-1.11.1/lib/../../activesupport/lib",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/activerecord-1.11.1/lib",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/activerecord-1.11.1/bin",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/activerecord-1.11.1/lib",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/activesupport-1.1.1/bin",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/activesupport-1.1.1/lib",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/rake-0.5.4/bin",
 "c:/prog/ruby/lib/ruby/gems/1.8/gems/rake-0.5.4/lib",
 "c:/prog/ruby/lib/ruby/site_ruby/1.8",
 "c:/prog/ruby/lib/ruby/site_ruby/1.8/i386-msvcrt",
 "c:/prog/ruby/lib/ruby/site_ruby",
 "c:/prog/ruby/lib/ruby/1.8",
 "c:/prog/ruby/lib/ruby/1.8/i386-mswin32",
 "."]

> After i uninstalled the watir gem, i was able to run my tests correctly.

BTW, using gems doesn't preclude being version-specific, unless you are 
using Edge Watir a lot, and dealing with cases that aren't packaged as gems:

http://docs.rubygems.org/read/chapter/4#page71

Devin