Hi Simon

> > > * if I put my cursor on 'self' the 'e' and 'f' are 
> > highlighted, weird.
> > >   (also happens with various other combinations of adjacent letters)
> > 
> > Have you installed RDE1.0.0beta3 version ? I had added 
> > FindMark property 
> > in 'Editor Property' form temporary, and I had hided it in RDE1.0.0.
> > Maybe this property is checked in the registry.
> 
> No, as I said, this was my first installation ever. The about box says
> "VERSION: 1.0.0.0". No hint on a beta version.

Ok, maybe, something bug is there. I will try to find and fix them.

> 
> The entry was empty:
> English_1000.xml   - ??(Y), ???(N), ?????
> EnglishA_0991.xml  - Yes, No, Cancel
> German_09xx.xml - ??(Y), ???(N), ?????
> German_0990.xml - Ja, Nein, Abbrechen
> 
> Ok, kind of solved for me.
> Are all these file in the 1.0.0.0 package?
> Is RDE bundled with any other Software? Maybe it was installed before
> without my knowledge?
> 

Yes, these are included in .exe installer version. 
But in first .zip distribution, they are not included. So I replaced
.zip version a few minutes ago. 


> > > * Some menu items have strange names (like the EndOfDefun above)
> > 
> > Please suggest the naming them in English. 
> > You can also rewrite them in TranslationFile.
> 
> Besides the strange underlining they seem to move the cursor to the
> next start/end of a block/method. Is this the (whole) suspected
> behaviour?

Case by case. These logic is beased on ruby-mode.el (old version) 
but I can not test them enough.

> (I can't make sense of the last 3 entries in the 'ruby' menu)

IndentCommand
	Cariculate and set indent in a current row or selection range. 
IndentReturnIndent
	IndentCommand & Input Enter & IndentCommand 
IndentReturnEasyParseIndent
	IndentCommand & Input Enter & EasyParse & IndentCommand 

> > This menu try to open http://rubyde.sourceforge.net/hiki/en/.
> > On my PC, this works well. 
> > If this don't work well, All menus in [Help] except 'Ruby Help' will
> > not work well.
> 
> This worked on another pc(WinXP) with mozilla, firefox does not start 
> here (Win2000). Can you give me a hint where to look? (double-click on
> a htm/html file works fine)

I used ShellExecute Windows API. This API launch related application.
I found the PC that RDE's helps are not work well. I will research this.

> > FindMark setting in registry make the problems.
> > Please check off FindMark setting by beta3.
> 
> I have to install beta3 do uncheck this setting?
> 
> I just renamed the whole RubyDE key in the registry editor, when
> I start RDE it shows me the configuration dialog and all the problems
> are still there. So I guess it has nothing to do with another (older)
> version.
> 
> Don't get me wrong. I would realy like to use your editor and (again) 
> it looks promissing - in fact it looks better than all the others
> clogging my recycle bin...
> 

OK. I want to solve them.
Can you upload the screen capture ( underlined ) to url below
https://sourceforge.net/tracker/?func=add&group_id=42751&atid=435759


-- 
sakazuki <qzs01353 / nifty.com>