Sorry for lack of context in reply - why oh why, Google Groups?

Anyway, the key line is

   Gem::LoadError: Could not find RubyGem extensions (>= 0.6.0)

Try

   gem dependencies rio
   gem list -l

Easiest of all: try

   gem install -r rio

which will install rio and all needed dependencies.

A standing RubyGems problem is that it doesn't do anything about
dependencies when you install a gem locally.

Cheers,
Gavin