On Wed, 2005-09-21 at 12:14 +0900, James Edward Gray II wrote:
> I just recompiled Ruby and I'm seeing a lot of issues already.
> 
> IRb is the first crisis I really need to tackle.  Are these error  
> messages making sense to anyone who can give me some clues?
> 
> Should I need to reinstall my gems, like Rails?
> 
> Neo:~/Desktop/ruby-1.8.3$ ruby -v
> ruby 1.8.3 (2005-09-21) [powerpc-darwin8.2.0]
> Neo:~/Desktop/ruby-1.8.3$ irb
> dyld: NSLinkModule() error
> dyld: Symbol not found: _rl_filename_completion_function
>    Referenced from: /usr/local/lib/ruby/1.8/powerpc-darwin8.2.0/ 
> readline.bundle
>    Expected in: flat namespace
> 
> Trace/BPT trap
> Neo:~/Desktop/ruby-1.8.3$ rails
> /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.1.1/lib/ 
> active_support/clean_logger.rb:13:in `remove_const': constant  
> Logger::Format not defined (NameError)
>          from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.1.1/ 
> lib/active_support/clean_logger.rb:13
>          from /usr/local/lib/ruby/site_ruby/1.8/rubygems/ 
> custom_require.rb:21:in `require'
>          from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.1.1/ 
> lib/active_support.rb:31
>          from /usr/local/lib/ruby/site_ruby/1.8/rubygems/ 
> custom_require.rb:21:in `require'
>          from /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.11.1/ 
> lib/active_record.rb:29
>          from /usr/local/lib/ruby/site_ruby/1.8/rubygems/ 
> custom_require.rb:21:in `require'
>          from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:182:in  
> `activate'
>          from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:181:in  
> `activate'
>          from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:167:in  
> `activate'
>          from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:166:in  
> `activate'
>          from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:37:in  
> `require_gem_with_options'
>          from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:31:in  
> `require_gem'
>          from /usr/local/bin/rails:17
> 
> Thanks for any advice.
> 
> James Edward Gray II
> 
> 

I had similar problems. Every Rails app I tried died... 

My advice:

cd ../ruby-1.8.2/; ./configure && make && make install

That's what I just had to do. No ruby 1.8.3 for me yet. :-/

-Robby

-- 
/******************************************************
* Robby Russell, Owner.Developer.Geek
* PLANET ARGON, Open Source Solutions & Web Hosting
* Portland, Oregon | p: 503.351.4730 | f: 815.642.4068
* www.planetargon.com | www.robbyonrails.com
*******************************************************/