Sorry for the late reply.

On Wed, Aug 10, 2005 at 10:32:15PM +0900, tony summerfelt wrote:
> Doug Kearns wrote on 8/9/2005 11:48 AM:
> 
> >>The last ``end'' is not highlighted.
> 
> > This was fixed a long time ago but unfortunately didn't make it upstream
> > for the vim6 release. 
> 
> it's not working for 6.3.86, compiled from source and all current
> patches applies (on windows as i mentioned in a prev. msg)

This is not really how the vim development model works. Having the
latest version of Vim itself is certainly no guarantee that you have the
latest runtime files. Obviously any major, or point, release of Vim
_should_ be an exception. ;-)

If you're having problems with any runtime file your first point of call
should always be the individual maintainer to make sure you are using
the latest version. The easiest way to do so is to check the URL header
which should point to the latest version or, if that is missing, send
the maintainer an email.

There's currently far too much manual updating of these files to ever
assume they're all in sync at a given point in time.

Regards,
Doug