Eric Hodel <drbrain / segment7.net> writes:

> On 12 Sep 2005, at 14:01, Peter Fitzgibbons wrote:
>
>> There's a comment in the docs
>>
>> http://www.ruby-doc.org/stdlib/libdoc/test/unit/rdoc/classes/Test/
>> Unit/A
>> ssertions.html#M000088
>>
>> #assert_raises
>> Alias of assert_raise. Will be deprecated in 1.9, and removed in 2.0.
>>
>> [Source]
>
> I would expect this if it had really been deprecated:
>
> $ ruby
> require 'cgi-lib'
> Warning:-:1: cgi-lib is deprecated after Ruby 1.8.1; use cgi instead

But the docs say it *will* be deprecated in 1.9, not it *is*
deprecated in 1.9, and 1.9 is not final yet. :-)

It wouldn't hurt to deprecate it soon, though.

> Eric Hodel
-- 
Christian Neukirchen  <chneukirchen / gmail.com>  http://chneukirchen.org