From: Unnsse Khan <untzkhan / yahoo.com>
Subject: Problem with Tcl/Tk in Ruby
Date: Tue, 13 Sep 2005 17:44:07 +0900
Message-ID: <BAY103-DAV2273B1B0EED1966420370DA9C0 / phx.gbl>,<E7A89D05-6671-4145-B099-921F0B5B2172 / yahoo.com>
> I am a Ruby newbie... I use Mac OS X Tiger and tried building a  
> simple Tcl/Tk widget and received an error message...
    (snip)
> Tk.mainloopRaven:/Developer/RubyEclipseWorkspace untz$ ruby iPsych.rb
> dyld: NSLinkModule() error
> dyld: Library not loaded: /usr/X11R6/lib/libX11.6.dylib

Probably, your tcltklib is compiled to use X Window System.
If you want to use Tcl/Tk framework, 
you have to give --enable-mac-tcltk-framework configure option. 
However, on Mac OS X Tiger, ext/tcltklib/extconf.rb fails to 
find Tcl/Tk framework because of change of framework directory. 
Please change "/Library/Frameworks/Tcl.framework/" and 
"/Library/Frameworks/Tk.framework/" on ext/tcltklib/extconf.rb
to "/System/Library/Frameworks/Tcl.framework/" and 
"/System/Library/Frameworks/Tk.framework/".
After that, remove old ext/tcltklib/Makefile, 
configure --enable-mac-tcltk-framework, and recompile it. 

If you don't mind to get source files from CVS, 
please get the latest version of ruby_1_8 branch
(and read ext/tcltklib/README.1st).
On the latest version, the problem and some other bugs are fixed.
-- 
Hidetoshi NAGAI (nagai / ai.kyutech.ac.jp)