Trans wrote:

> So foo-bang, foo-p, foo-set, and class-foo, plus I might as well do:
> 
>      {
>        "+"	=> "op-plus",
>        "-"	=> "op-minus",
>        "+@"	=> "op-plus-self",
>        "-@"	=> "op-minus-self",
> [...]
>      }
> 
> I thik also I'd like to reduce all of them to a single dash if
> reasonably possible, which would change a few of them.
> 
> What do you think of this?

Let me give a late okay to this. My mapping was initially for going from 
method names to names for test methods so using - was no option for me. 
It makes sense here and helps with avoiding collisions.

What was the motivation for this? Sure: It is mostly transparent if you 
use the custom require or escaping functionality you provide, but what 
if I want to do a patch for a file or have a look at the implementation 
of something? Here it really helps if the files are intuitively named.