Hi gurus and nubys,

I just realized that it is a common idiom to put a TestCase in a single 
file, but this convention could be made easier to use.

IMO it would be nice to have

  require 'test/unit'
  def test_foo
  end

instead of
  require test/unit
  class TC_FooBar < Test::Unit::TestCase
   def test_foo
    ..
   end
  end

not a big deal, I know :)

I think it should be easy to do this, by mixing the code from the file 
in a custom object, or building a whole new TestCase subclass 
dynamically. #setup and #teardown methods should still work fine, I 
think. The name for the TestCase could be taken from the filename, 
becoming a little more DRYish.

This is a departure from the xUnit heritage, but I think that taking 
advantage of ruby's features and make Test::Unit simpler to use by 
"evolving" it a little bit was already planned. Is this a bad idea?