Jeff Wood wrote:
> Wow, I'd say that the punctionation ( with conversion or not ) should
> come out of the filenames... the %3A stuff is about as un-user-friendly
> as anything I've ever seen.

You'd have to have a better alternative, and I can't think of one. 
Consistent naming's important, and I'd rather not be using interesting 
suffixes like "nano/array/rotate_bang".

To ease the pain, instead of:
  require 'nano/array/rotate%21'
nano provides:
  require 'nanoreq'  # or nanosys or nano or nano/base
  require_nano 'array/rotate!'
and I presume mega has an analog.

Cheers,
Dave