Hi,
Just a suggestion, if you don't have a sample of an app embedding ruby or if
you want another one, you can take
a look at the way vim handles that go to www.vim.org, I'd suggest you
download the latest 60 alpha.  The error
code seems to be correctly handled since I've never had a ruby error bomb
the editor I just get the appropriate
error message.
Benoit