Hey Park, looks great. We can tell that you're putting a lot into this
lib. And aren't you supposed to be new to this ruby thing :) You're
doing great.

Minor note: you have a number of methods that have the name 'get_this'
and 'get_that'. Consider leaving the 'get' out of the name. In other
languages, get methods are common to distinguish methods from public
members, but since everything is a method in ruby, people tend to
leave out the 'get'. So, basically, you'd have g.messages instead of
g.get_messages and g.labels instead of g.get_labels.

I put it on the tracker to make this suggestion 'official'.

Perhaps other people on this list can confirm/dispute that this would
be preferred.

Dan