Alex,
This could be a problem because of 3rd party winsock components
installed on your machine.This is possible if you use some kind of VPN
software.

I was facing the same problem and one of the messages on this list
went into details.
Search for "RubyGems or any HTTP on XP NOT working" on ruby-talk...

I uninstalled the component and now I dont face any problems.. 

hope this helps

Thanks,
Amit

On 8/22/05, Alex Nedelcu <alexandru.nedelcu / gmail.com> wrote:
> Thank you but that wasn't it.
> 
> I upgraded to 0.8.11 and nothing happened.
> 
> But I found the problem (I am posting it for others to see it):
> 
> I used ZoneAlarm as my firewall and even though I stopped it before I
> executed gems apparently it still had been running some process in
> background preventing gems from executing. So I had to uninstall
> ZoneAlarm in order for gems to work.
> 
> Since ZoneAlarm is a popular firewall, maybe this behaviour should be
> documented on the RubyGems website, no ?
> 
> 
>