No, I think it is the same problem.

Well, when I install some new gem I don't mind downloading it manually,
but the command "gem update" it is really usefull and it sucks that it
doesn't work.