I provide sys admin support to over 200 RS/6000 running from AIX 4.3.3
to AIX 5.3.
bullfreeware.com offers a binary for AIX (Ruby 1.8.2 for AIX 5.2 (not
tested)). This is a good start but socket does not work. I have a
small number of ruby 1.6.7 under AIX 4.3.3 with socket support. I need
to be liberated from Korn Shell, but until I get a Ruby build that
works on every server, I have to stick to Korn Shell. All my efforts
to build a working Ruby 1.8.2 or higher on 4.3.3 and 5.3 had been a
big disappointment and frustration.

Anyway, just sharing my frustration!


On 8/19/05, Molitor, Stephen L <Stephen.L.Molitor / erac.com> wrote:
> Me four.  This is the hold up in getting Ruby approved at our company.
> They don't want to approve a Perl scripting replacement unless it runs
> on all our machines.  Most of our servers are AIX.
> 
> :(
> 
> Steve
> 
> -----Original Message-----
> From: Victor Reyes [mailto:victor.reyes / gmail.com]
> Sent: Friday, August 19, 2005 2:53 PM
> To: ruby-talk ML
> Subject: Re: AIX and Ruby issues (still)
> 
> Me three!
> 
> On 8/19/05, bww00amdahl / yahoo.com <bww00amdahl / yahoo.com> wrote:
> > I need an AIX build also.
> >
> >
> > Thanks
> > Bryan Webb
> >
> >
> > ober wrote:
> > > I know this is a thorn to bring up every so often.
> > > But I have yet to find either an AIX package for 5.x or instructions
> 
> > > on how to build 1.8.2 with sockets that actually work.
> > > I did get one build once, but it failed with errors trying to use
> SOAP.
> > >
> > > Has anyone any new info on the AIX port?
> > >
> > > Thanks in Advance
> > >
> > > Ober
> >
> >
> >
> 
> 
>