The 'mysql' gem only provides the Ruby bindings to the MySQL client API
-- you have to separately install the MySQL libraries for your system.
I'm going to go out on a limb and assume you're trying to run Ruby on
Rails, (and hence posted this question here) you'll probably want the
full MySQL server installation, as well.

Basically, go to mysql.com, download the latest Windows distribution,
and make sure your MySQL install is working before trying to install
the Ruby bindings.

-Lennon