rio4ruby wrote:

 >I am pleased to announce the first public release of Rio -- Rio 0.3.1

I tried this - what am I doing wrong?:

root>gem install rio --remote
Attempting remote installation of 'rio'
Successfully installed rio-0.3.1
Installing RDoc documentation for rio-0.3.1...
Could not find main page  RIO::Doc::SYNOPSIS
Could not find main page  RIO::Doc::SYNOPSIS
Could not find main page  RIO::Doc::SYNOPSIS
Could not find main page  RIO::Doc::SYNOPSIS
root>updatedb
root>locate rio.rb
/usr/local/lib/ruby/gems/1.8/gems/rio-0.3.1/doc/generators/template/html/rio.rb
/usr/local/lib/ruby/gems/1.8/gems/rio-0.3.1/lib/rio.rb
/usr/local/lib/ruby/gems/1.8/gems/rio-0.3.1/lib/rio/scheme/strio.rb
/usr/local/lib/ruby/gems/1.8/gems/rio-0.3.1/lib/rio/to_rio.rb
root>irb
irb(main):001:0> require 'rio'
LoadError: No such file to load -- rio
 from (irb):1:in `require'
 from (irb):1
irb(main):002:0> puts $LOAD_PATH
/home/local/ruby
/usr/local/lib/ruby
/usr/local/lib/ruby/site_ruby/1.8
/usr/local/lib/ruby/site_ruby/1.8/i686-linux
/usr/local/lib/ruby/site_ruby
/usr/local/lib/ruby/1.8
/usr/local/lib/ruby/1.8/i686-linux
.
=> nil
irb(main):003:0>

-- 
Wybo