Florian Gro <florgro / gmail.com> writes:

> Thought about it shortly as well while browsing through the
> keyword file, but I think that this just looks off:
>
> make_counter = do(start=0) do
>    do do
>      start += 1
>    end
> end

Yeah... that looks, uh, off. :-)

> OTOH I'm not sure I see the problem with changing
> lambda or fun.

I agree, making lambda a special form seems like the
best solution.  At least make `lambda' a synonym for `->'.

-- 
Daniel Brockman <daniel / brockman.se>