Eric Mahurin <eric_mahurin / yahoo.com> wrote:
> 
> Still kind of ugly though.  Too bad you have to leave hashes as
> first-class.  If you made them second class instead (
> hash(key=>value,...) or Hash.new(key=>value,...)), that would
> allow more freedom.  I think code blocks are much more
> important than hashes.

That's rather drastic. All it needs is a new symbol for literal hashes.
(I like [| |] myself.)

martin