>Now ruby(HEAD) accepts the notation '->(...){...}'

I like that new block notation as well.  Somehow it's always felt just the 
slightest bit 'off', to me, to specify a block's arguments within the 
block...  The new notation seperates the specification of a block's 
arguments (which doesn't really belong *in* the block, somehow, IMO) from 
the code that says what you're going to *do* with those arguments (which 
certainly does belong in the block)...  The new way feels just a slight bit 
more correct, somehow.