Adrian Petru Dimulescu wrote:

> So I can't seem to be able to use the log4r package installed via gem.

I think depending on how you installed gems, you might need to use 
require_gem instead of require:

require_gem 'log4r'