On Mon, 25 Jul 2005, Trans wrote:

> Wondering the general feeling about using the class namespace for
> subclasses. Basically I have a number of specialized Hash classes:
> OrderedHash, SyncHash, StaticHash. But I'm thinking it might be more
> elegant to name them: Hash::Ordered, Hash::Sync, Hash::Static. Is that
> a better way to go or no?
>
> Thanks,
> T.

i'd do

   module HashTable
     class Ordered; end
     class Sync; end
     class Static; end
   end

cheers.

-a
-- 
===============================================================================
| email :: ara [dot] t [dot] howard [at] noaa [dot] gov
| phone :: 303.497.6469
| My religion is very simple.  My religion is kindness.
| --Tenzin Gyatso
===============================================================================