Trans wrote:
> Wondering the general feeling about using the class namespace for
> subclasses. Basically I have a number of specialized Hash classes:
> OrderedHash, SyncHash, StaticHash. But I'm thinking it might be more
> elegant to name them: Hash::Ordered, Hash::Sync, Hash::Static. Is that
> a better way to go or no?
> 
> Thanks,
> T.
> 
Use a module to contain the classes:

module Hash
    class Ordered
    ...
    end
    class Sync
    ...
    end
    class Static
    ...
    end
end

myhash = Hash::Ordered.new