I've installed ruby 0.8.11 on Linux i686 in a non-standard path, as I'm
using a hosted server without perms to /usr/local

Anytime I try to install a package, I get 'require' errors:

For instance, this is my ruby ./configure:

[ruby-0.8.11]$./configure --prefix=/home/jpprice

Now after ruby is installed, everything complains about required files,
the majority of which seem to be in

 /home/jpprice/lib/ruby/1.8/

Here's a typical example:

/usr/home/jpprice/lib/ruby/1.8/date.rb:197:in `require': No such file
to load -- date/format (LoadError)

I've tried things like putting /home/jpprice/ and
/home/jpprice/lib/ruby/1.8 in my PATH, but nothing seems to work
properly.

What do I have to do to get ruby running properly?

Thanks,

Patrick
groups @ jpprice . info