Hello Stephen,

SK> In message <dcedf5e205071907177b0215cd / mail.gmail.com>, Cameron McBride
SK> <cameron.mcbride / gmail.com> writes
>>> RMV runs on Windows NT 4.0/W2K/XP or better.
>>
>>why this platform requirement?

SK> Because we don't have the time or manpower to provide a Linux port at
SK> this time. It is impossible to write something like RMV without using
SK> C++/assembler and patching the Ruby binary at runtime to get access to
SK> the object creation and destruction methods. You cannot do this with
SK> Ruby/Python/Perl/Java/etc. Even if you could they would be too slow for
SK> this type of thing.

See you had to do the same as i did for my debugger.
Whats about a standard "ruby_d.exe" which adds more hooks into the
virtual engine and still works with all extensions ?


-- 
 Best regards,                        emailto: scholz at scriptolutions dot com
 Lothar Scholz                        http://www.ruby-ide.com
 CTO Scriptolutions                   Ruby, PHP, Python IDE 's