On 7/18/05, Michael Campbell <michael.campbell / gmail.com> wrote:
> On 7/17/05, Devin Mullins <twifkak / comcast.net> wrote:
> > My feeling is the exact opposite. I think
> >     assert foo.respond_to? bar
> > is immensely more readable than.
> >     assert(foo.respond_to?(bar))
> And others will disagree.
> 
> I don't like e e cummings, either.

I think that this could be readable, but we're probably reaching for
SmallTalk at this point:

  assert: foo.respond_to? bar

The problem, ultimately, is that you can't meaningfully do:

  foo bar baz, moomin snufkin

There's too many possible meanings for that:
  foo(bar(baz), moomin(snufkin))
  foo(bar(baz, moomin(snufkin)))
  foo(bar(baz)), moomin(snufkin)

I am not particularly fond of the idea that arguments to a method
would bind to the nearest method.

-austin
-- 
Austin Ziegler * halostatue / gmail.com
               * Alternate: austin / halostatue.ca