I'm trying to install rubygems-0.8.10 on ruby 1.8.2 on Cygwin.

Any idea of what's wrong?

Thanks for your help,
Steve Kelem

   Here are the messages I get:
% ruby setup.rb
---> bin
<--- bin
---> bin
<--- bin
rm -f InstalledFiles
---> bin
mkdir -p /usr/local/bin/
install gem /usr/local/bin/
install gemwhich /usr/local/bin/
install gem_server /usr/local/bin/
install generate_yaml_index.rb /usr/local/bin/
install update_rubygems /usr/local/bin/
<--- bin

As of RubyGems 0.8.0, library stubs are no longer needed.
Searching $LOAD_PATH for stubs to optionally delete (may take a while)...
....done.
No library stubs found.

/usr/local/src/rubygems-0.8.10/./post-install.rb:62:in `require': No 
such file to load -- rubygems (
LoadError)
         from /usr/local/src/rubygems-0.8.10/./post-install.rb:62:in 
`install_sources'
         from /usr/local/src/rubygems-0.8.10/./post-install.rb:74:in 
`instance_eval'
         from setup.rb:583:in `instance_eval'
         from setup.rb:583:in `try_run_hook'
         from setup.rb:577:in `run_hook'
         from setup.rb:1315:in `exec_task_traverse'
         from setup.rb:1168:in `exec_install'
         from setup.rb:887:in `exec_install'
         from setup.rb:705:in `invoke'
         from setup.rb:674:in `invoke'
         from setup.rb:1352